Post Loop ไม่แสดง Featured Image ที่หน้า Post type

หน้าแรก ฟอรั่ม ถามปัญหาการทำเว็บด้วยเวิร์ดเพรส Post Loop ไม่แสดง Featured Image ที่หน้า Post type

กำลังดู 3 ความเห็น
  • ผู้เขียน
    ข้อความ
    • #255732

      สวัสดีครับพี่เม่นและทีมงาน

      ปัญหาที่เจอคือผมได้ทำการสร้างหน้า single-pattanistory.php ซึ่งเป็นหน้าแสดงข้อมูลของ Custom Post Type ทีนี้ในส่วน footer ผมได้สร้าง Post Loop เรื่องที่เกี่ยวข้องขึ้นมา ซึ่งแสดงผลแค่ชื่อและข้อความโปรย แต่ไม่ปรากฏรูป featured

      ลองดูตัวอย่างที่ http://pattaniheritagecity.psu.ac.th/pattanistory/%e0%b8%a7%e0%b8%b1%e0%b8%87%e0%b9%80%e0%b8%88%e0%b9%89%e0%b8%b2%e0%b9%80%e0%b8%a1%e0%b8%b7%e0%b8%ad%e0%b8%87%e0%b9%82%e0%b8%9a%e0%b8%a3%e0%b8%b2%e0%b8%93-%e0%b8%aa%e0%b8%b2%e0%b8%a2%e0%b8%9a/

       

      แต่ถ้าเอา Post Loop นี้ไปแสดงหน้าอื่น จะขึ้นมาครบถ้วนครับ จึงอยากทราบว่าในหน้า Custom Post Type มันไปซ่อนรูปได้อย่างไรครับ

      ขอความช่วยเหลือด้วยครับ

    • #255761
      Facebook Profile photoK
      Keymaster

      ถ้าเดาคิดวาจุดที่ไปวางโค้ดไว้ไม่ได้อยู่ใน loop ของ query ที่ต้องการนะครับ

      • #255774

        รบกวนคุณเคช่วยขยายความเพิ่มได้ไหมครับ

        ผมใช้วิธีการสร้าง Layout ด้วย Siteorigin ใน widget แล้วกำหนดให้มันแสดงเฉพาะหน้าที่อยู่ในหมวด category นี้ครับ

        ผมควรต้องปรับแก้อย่างไรครับ

    • #255941
      Facebook Profile photoK
      Keymaster

      ถ้าดูในโค้ด single.php หรือ single ที่คุณกิตติศักดิ์สร้างจะมี โค้ดที่ประมาณ have post the post อยู่ในครับ ซึ่งปกติ พวก title หรือ featured image ต้องอยู่ภายในโค้ดนี้มันถึงจะดึงไอดของตัวมันได้ถูกต้องนะครับ

      ซึ่งผมคิดว่าตรง footer ไม่น่าจะอยู่ภายใต้โค้ดชุดนี้เลยทำให้มีปัญหานะครับ

    • #255955

      ขอบคุณมากครับ ยังไงผมจะลองแก้ไขดูครับ

กำลังดู 3 ความเห็น

  • คุณต้องเข้าสู่ระบบเพื่อตอบกลับกระทู้นี้